To use chat, please login.
Back to contacts

Channel Trader PRO (By channeltraderpro )

Gain : +2137.11%
Drawdown 33.68%
Pips: 2948.2
Trades 589
Won:
Lost:
Type: Real
Leverage: 1:100
Trading: Automated

Channel Trader PRO Discussion

tellanup
Oct 13 2015 at 18:33
129 posts
thanks Rob , appreciate it

fxtrader10
Oct 13 2015 at 18:35
226 posts
Dionysus231 posted:
So far I really like it. I did 3 trades yesterday. All of them are in profit almost immediately. One is up 117 pips. One is up 53 pips and the other 35 pips. We will see how the week goes.


Thanks for the update.

What were you provided with upon purchase exactly?

I wonder why it cannot be automated.

bbulcsu72
Oct 13 2015 at 19:35
17 posts
Same for me, both VTP and CTP had the same Account was not found for ID xxxx error. What happened?

TradeNew
Oct 13 2015 at 19:56
70 posts
bbulcsu72 posted:
Same for me, both VTP and CTP had the same Account was not found for ID xxxx error. What happened?


Activate again. Was discussed before...

CupidAlaska
Oct 14 2015 at 06:33
10 posts
Has anyone else's CTP stopped working since the last big loss? Mine keeps saying account ID is not found??

fx883
Oct 14 2015 at 06:33
10 posts
It looks like the STP uses linear regression channels, which at some point will 'repaint.' Not knocking the system, as I'm a fan of Doug's and his strategies, but just something to keep in mind when you look at still-frame screenshots.

Success is no accident. It is hard work, perseverance, learning, studying, sacrifice and most of all, love of what you are doing.
bbulcsu72
Oct 14 2015 at 07:54
17 posts
TradeNew posted:
bbulcsu72 posted:
Same for me, both VTP and CTP had the same Account was not found for ID xxxx error. What happened?


Activate again. Was discussed before...


Thanks for that, it's Ok now.

webdude2000 (webdude2000)
Oct 14 2015 at 13:45
36 posts
We are back in action...

CupidAlaska
Oct 15 2015 at 06:01
10 posts
Mine is still not working, am I missing something? Thanks

webdude2000 (webdude2000)
Oct 15 2015 at 10:00
36 posts
CupidAlaska posted:
Mine is still not working, am I missing something? Thanks


You have to re-activate it on the web site. The site link is in the user guide PDF you received with the EA.

Please login to comment .