Http-Proxy Server for MyfxbookEA.dll Votes Results
Podoba Ci się ta propozycja ?

 
Http-Proxy Server for MyfxbookEA.dll Discussion
Ocena: Empty Star Empty Star Empty Star Empty Star Empty Star
Poprzedni 1 2 Następny
SniperNCE

Członek od Jul 29, 2010  13 postów SniperNCE Sep 17 2010 at 09:40
I agree. Would be nice to have some settings for the proxy.

Staff

Członek od Jul 31, 2009  1385 postów Ethan (Staff) Sep 17 2010 at 12:32

bubincka64 posted:
    Sorry, maybe i can't explain well to let you understand my issue. I try again.
Mine is a Company Proxy, managed by the network admin and I can't configure it. All I have is the proxy name and port.
But while in Metatrader you can use the Server/Proxy... panel to tell the platform what the proxy:port is, in your Myfxbook EA you can't and it actually use the proxy but on the default port 80, so it doesn't work. As suggested by member SniperNCE adding to the EA some input parameters like proxy & port should solve the problem.


I meant to configure the network connection of your PC, not the proxy itself.

bubincka64

Członek od Sep 16, 2010  7 postów bubincka64 Sep 17 2010 at 12:51
In my PC network settings under Tools\Internet Options\Connections\ LAN Settings I have

-- Proxy server
Address: Port:

In God We Trust
bubincka64

Członek od Sep 16, 2010  7 postów bubincka64 Sep 17 2010 at 12:54
In my PC network settings under Tools\Internet Options\Connections\ LAN Settings I have

-- Proxy server
              
Address: Port:

In Address I put the name/IP of the company-proxy and in the port I can only put the value 3128 because the proxy only accepts connections on that port number. If I put 80 it doesn't work.

I hope now you have understood what's the problem.

In God We Trust
bubincka64

Członek od Sep 16, 2010  7 postów bubincka64 Sep 17 2010 at 14:49
Hi, to answer your question, yes, if i set the 3128 proxy in my network connection, I can browse the web.
And i can also connect my Metatrader to the datacenter.

Instead the EA Myfxbook doesn't work in metatrader log only tells HTTP Error.
I checked with netstat and as i already told you the EA goes on port 80 and not 3128, that's the reason why it's blocked. The details of netstat are:

validation.myfxbook.com:http for the remote address.

In the meanwhile I have other 2 accounts on another server *without* proxy that work perfectly on Myfxbook.

In God We Trust
Hattrick

Członek od Sep 27, 2010  4 postów Hattrick Oct 14 2010 at 08:05
I have the same problem. I'm using a proxy and web browsing and metatrader is working fine.
myfxbook expert is not working.
Any solution ?

Staff

Członek od Jul 31, 2009  1385 postów Ethan (Staff) Oct 14 2010 at 08:21

Hattrick posted:
    I have the same problem. I'm using a proxy and web browsing and metatrader is working fine.
myfxbook expert is not working.
Any solution ?


We're working on it, so it should be ready soon.

Staff

Członek od Jul 31, 2009  1385 postów Ethan (Staff) Oct 20 2010 at 06:54
Although we're working on an EA version with a proxy option of its own, if you have a proxy configured in your windows and you can browse the web, this should work:

1. Open CMD (Run > cmd)
2. Type: 'proxycfg -u' (without the ')
3. Check the result in MetaTrader.

Hattrick

Członek od Sep 27, 2010  4 postów Hattrick Oct 20 2010 at 14:52
Thank you very much for the solution. I tested on Windows XP and it's working.
Proxycfg is not available for win 2008 server and Windows 7. For those systems you can use 'netsh'

https://www.bohack.com/2010/08/windows-server-2008-replacement-of-proxycfg-exe/

Hattrick

Członek od Sep 27, 2010  4 postów Hattrick Nov 19 2010 at 00:02
I read somewhere on the site that you have a beta version that use proxy.
Can i try it ?

Aby dodawać komentarze musisz być zalogowany.
Loading
Loading
EURUSD 1.18363 GBPUSD 1.33096
USDJPY 104.512 USDCAD 1.30947

Narzędzia

Społeczność

Opinie

Brokerzy

Platforma

Wsparcie


Twitter |  Facebook |  Mapa strony  |  Zasady  |   Polityka prywatności
©2020 Myfxbook Ltd. All Rights Reserved.
HIGH RISK WARNING: Foreign exchange trading carries a high level of risk that may not be suitable for all investors. Leverage creates additional risk and loss exposure. Before you decide to trade foreign exchange, carefully consider your investment objectives, experience level, and risk tolerance. You could lose some or all of your initial investment; do not invest money that you cannot afford to lose. Educate yourself on the risks associated with foreign exchange trading, and seek advice from an independent financial or tax advisor if you have any questions. Any data and information is provided 'as is' solely for informational purposes, and is not intended for trading purposes or advice. Past performance is not indicative of future results.