To use chat, please login.
Back to contacts

Strategy Tester Question

bestdarngood
Jul 25 2011 at 13:04
174 posts
I notice that when I run the strategy tester on the weekend during hours that the Forex market is not open, the results are not fully as expected. Does the data not update during these hours? Possibly the server my Metatrader connects to is down? Anyone know the specific reason that my software trades oddly especially with the newer data? It tests fine once the market is open again. In both instances it trades, it just seems to trade differently from how it should when it trades off hours.

thanks guys

See my profile or message me for my latest EA
James_Bond
Jul 25 2011 at 16:10
556 posts

bestdarngood posted:
    I notice that when I run the strategy tester on the weekend during hours that the Forex market is not open, the results are not fully as expected. Does the data not update during these hours? Possibly the server my Metatrader connects to is down? Anyone know the specific reason that my software trades oddly especially with the newer data? It tests fine once the market is open again. In both instances it trades, it just seems to trade differently from how it should when it trades off hours.

thanks guys


The data is taken from your broker's servers as far as I'm aware. Obviously, if you test it on a different time spans, you'll get different results.

Or are you saying you're testing it on different timeOfWeek/timeOfDay?

bestdarngood
Jul 25 2011 at 17:08
174 posts
I'm testing it on same timespan but sometimes test on a weekday when the market is active and sometimes on a saturday when it is not and with everything the same in the program, I will get different results

See my profile or message me for my latest EA
zzzero
Jul 25 2011 at 21:41
1367 posts
strategy tester is not very good, anyways..

i have written EA's that, when ran in the strategy tester, straight up blew up the entire platforrm.

ea's that work in strrateegy testere do not alwayss worrk inn realtime.

i wrrotee one that took 1k annd turned it into somethingn likee huundnredss of millionss of dollaarss, but it faialed it's first day off trrading demo money.

z/.


bestdarngood
Jul 26 2011 at 01:22
174 posts
Well, it is better than nothing for testing and it seems to work for me as long as I test within trading hours but thanks for your input.

See my profile or message me for my latest EA
James_Bond
Jul 26 2011 at 06:27
556 posts

bestdarngood posted:
    I'm testing it on same timespan but sometimes test on a weekday when the market is active and sometimes on a saturday when it is not and with everything the same in the program, I will get different results


How much of a different result are we talking about here? What type of testing model are you using? Ticks/open prices/control points?

bestdarngood
Jul 26 2011 at 12:13
174 posts
Well many times it seems like the newer points are off because it makes many more bad trades at the end and I believe also in other parts possibly of the time span that the program is tested on. Every Tick is the testing method used without optimization.

See my profile or message me for my latest EA
James_Bond
Jul 26 2011 at 14:20
556 posts

bestdarngood posted:
    Well many times it seems like the newer points are off because it makes many more bad trades at the end and I believe also in other parts possibly of the time span that the program is tested on. Every Tick is the testing method used without optimization.


It sounds like you have flawed login in your EA - if you're getting an entirely different result on each backtest using the same data, there must be something wrong.

bestdarngood
Jul 26 2011 at 17:02
174 posts
I get the same result from one week to the next DURING trading hours for sure, but I'm not going to worry about it, just wanted to see if anyone else saw this issue ever. I have seen it on both of my computers but no big deal. I just can't test on the weekends and guarantee good data.

See my profile or message me for my latest EA
James_Bond
Jul 26 2011 at 18:00
556 posts
I've never experienced such issues. Do you get such behavior with all EA's or only yours?

Please login to comment .