To use chat, please login.
Back to contacts

MyFxBook EA and Metatrader 4 - Build 600

Myfxbook (Staff)
Feb 14 2014 at 10:03
1407 posts
@jdowney @tange

Please send an email to support [at] and state your operating systems, any running firewalls, the mode you're running mt4 (ie as administrator and/or portable) and any errors you're getting.

Abdul Rupar bin Abdul Wahab (ruparaw)
Feb 15 2014 at 01:00
54 posts
Staff posted:
Please use the latest version as there are no issues with it as far as we're aware:

tq sir everything is working as normal now 😄
Not greedy is the most important factor on your FOREX sucsessfullness.
Matt (BluePanther)
Feb 15 2014 at 15:41
1358 posts
Really unhappy with the forced upgrade to 600.

Now, will MetaQuotes compensate those traders that suffer loss of income because their EAs will no longer work on the new build?

Or what of all the many companies which sell EAs or provide signal services (not to mention the plethora of brokers that depend on MT4) that will now suffer economic loss as a result of this forced update to a botched version?

One day the platform works fine, the next day everything stops working. How should the trading community view such an act?

If MQ were based in the US surely this could be considered an act of terrorism, and thus they would be in violation of Federal laws and should be punished to the full extent of the law.

Any lawyers out there in cyberspace willing to take up our cause and sue MetaQuotes for damages?

The court should at least force MetaQuotes to open its source code to the public so that it becomes free open source software, not black-box proprietary software.

I know I'm dreaming, but surely I'm not the only one...?
Matt (BluePanther)
Feb 15 2014 at 16:11
1358 posts
Hmm, well, I installed the new Myfxbook EA, and I got a new error:

2014.02.15 11:02:16.381 Cannot load 'C:\Users\Administrator\AppData\Roaming\MetaQuotes\Terminal\C99F096D87CEFCF493233C12C6AD11E1\MQL4\Libraries\Kernel32.dll'

No I can't do a better job, but MQ should know what they are doing (they are SUPPOSED to be professionals, but this raises serious questions about their understanding and/or ethics)! Build 600 has been just a shemozzle. 😞

A great free product has just turned to crap overnight... anyone thinking about reverse-engineering an MT4 build less than 600 so we can start a free open source trading platform without MQ's stupidity?
Matt (BluePanther)
Feb 15 2014 at 17:50
1358 posts

MetaQuotes does some really f*cked up sh*t (apart from forced updates to botched versions).

Next thing you know, MQ will force an update to a version containing a virus or spyware to everyone's computers, all in their insatiable hunger for greed and power.

Actions speak louder than words: their actions say a lot about them as a company. They don't care about their own reputation, about what others may think of them, or about the effect their actions have on the end users (us). Seems their confidence in market share has gone to their heads and it is about time people started waking up and thinking about other trading platform alternatives.
Feb 16 2014 at 07:19
4 posts
Now here's a thing... All four of my platforms (4 brokers) updated themselves on my VPS... but on my home PC they are still build 509... No sign of an auto-update theire. ... However, for some reason my internet explorer 11 browser now doesnt operate some buttons to select a drop down menu on a couple of internet web pages. This started at the same time as these updates, but surely it cant be connected? Firefox is okay. Strange. Maybe its just me.

 I think that blue panther does have some grounds for what he says though. Why cant we just have a product that just works?
JD (jdowney)
Feb 16 2014 at 07:50
5 posts
Can we go back to the previous build?????????????

Myfxbook accounts says it has updated, but it has not, my stats are exactly the same as they were before my MT4 platform was upgraded.
I have not errors on my MT4, I wonder if it is the EA from myfxbook that is causing the problems.

Still awaiting a reply from myfxbook support.

Myfxbook (Staff)
Feb 16 2014 at 09:13
1407 posts
@BluePanther Please make sure you've installed the EA as administrator as well as running your MT4 as administrator.
JD (jdowney)
Feb 16 2014 at 10:51
5 posts
I have done that as administrator. Still have the same problem, myfxbook says its updated, but the stats are still the same as there 5 days ago just before my MT4 platform upgraded.
Myfxbook (Staff)
Feb 16 2014 at 10:53
1407 posts
jdowney posted:
I have done that as administrator. Still have the same problem, myfxbook says its updated, but the stats are still the same as there 5 days ago just before my MT4 platform upgraded.

Please check your email. We need to check your pc/vps in order to isolate the issue as the dev team can't replicate this error on their end.
Feb 17 2014 at 09:47
3 posts
I had same issues with EA showing updated, but not actually updating data, tried running terminal as Admin but still did not update, but after re-installing EA as 'Administrator' worked a treat, hope this helps.
Feb 17 2014 at 13:30
1 posts
Hi nice to meet you, I'm Chinese
Myfxbook (Staff)
Feb 18 2014 at 16:07
1407 posts
We've just released a new build 1.72 which you can download here (install in administrator mode):

This build will fix the following issues:
- Incorrect installation when installing as a user with no admin rights (causes missing files) - due to change in folder architecture of MT4.
- Old statements uploaded (this is due to bugs in MT's build below version 610 which do not offer full compatibility for previous builds).

Bob Simpson (rpsimpson)
Feb 18 2014 at 22:43
2 posts
I am on build 600. Installed 1.71 Myfxbook looks like it is working except that the monthly history for was at 0% but the yearly values are OK. The issue that I have is on how to attach a screen shot to the comments section of a trade. I an using an ea to place trades. This ea takes a screen shot & stores this in the open data folder>MQL4> files. When I 'browse' I cannot see the 'open data > MQL4> Files location. I also cannot find this location when using the windows explorer?
Feb 20 2014 at 09:17
61 posts
I am using the latest version of the EA on my VPS and there doesn't seem to be any errors in the expert tab, but there isn't any history uploaded to MyFXBook even though I have all the history showing in the Account History.When I ran the EA to install it as Administrator I received the following message:

I pressed continue and it seemed to install correctly, but I assume that it did not as the hisrtory is not being updated.

Any ideas anyone?
JD (jdowney)
Feb 20 2014 at 09:24
5 posts
I have had the same problem after downloading the latest EAInstaller 1.7.2 But looking at the version is has not updated by the look of things. it is still 1.7 and not 1.7.2


Feb 20 2014 at 11:06
18 posts
Hi guys,

I had the same error (ie: the .NET error) also when I attempted to install version 1.72, and the installation was unsuccessful as a result. In the end I manually copied the files provided by SolidPips in his post from Feb 7th (see below for the instructions from his post), and it all worked fine. You may have to go to his actual post to get the files.

Abago posted:
Here is a solution to get myfxbook to work with Build 600 of MT4:

1) Download the attached files and unzip them
2) To make sure you are in the correct folder when you do step 3) below, open MT4 and then click on File and then click on Open Data Folder.
3) Add Myfxbook.ex4 into MQL4\Experts folder, and both Mql5HttpLib.ex4 and zlib_wrapper.dll into MQL4\Libraries folder.
Feb 20 2014 at 14:17
61 posts
Thanks tcollings - that worked perfectly for me! :)
Myfxbook (Staff)
Feb 23 2014 at 15:27
1407 posts
@jdowney @DMFXTrader

The issue is caused when using obsolete operating systems such as Windows XP and, Windows 2000 etc'. We've issued a fix for this in the new version 1.7.3 - you can download it and use it from the same url:

Thanks for reporting it!
Ken Grakauskas (Michigander)
Feb 23 2014 at 22:54
321 posts
MetaQuotes just seems to get more obnoxious by the day. Force an upgrade. If your EA's don't work, tough shit.

This is business as usual now folks. All updates from now on will be automatic and done without your knowledge or consent. You can control them though.

You have a file folder called C:\Program Data\Metaquotes. Delete it. This folder only controls the installation updates. As long as you delete the folder before you open your platform, your system will stay on the currently installed build.

I put a shortcut to this file on my desktop. I have been controlling this now for a couple weeks, and migrating from build 509 on my terms, no theirs. When deleted on the weekend, it comes back every half hour or so. When deleted during the week, it doesn't seem to come back till Friday after the market close.

War is when your government tells you who the enemy is. Revolution is when you figure out, for yourself, who the enemy is.
Please login to comment .