To use chat, please login.
Back to contacts

MyFxBook EA and Metatrader 4 - Build 600

Kitot (kitot)
Feb 06 2014 at 07:30
6 posts
I read in 'MetaTrader 4 Build 600 with Updated MQL4 Language and Market of Applications Released'
https://forum.mql4.com/60555

'f MQL4 programs contain DLLs for passing/accepting price data, the corresponding functions in the source codes should be rewritten and recompiled considering format changes to ensure proper operation.

Old EX4 applications and DLLs based on old RateInfo format will not work in the new terminal. Conversion to the new format is required.'

Probably, the problem is because the DLL used by MyfxbookEA can't be used in the new MT4 build.

Kitot (kitot)
Feb 06 2014 at 07:30
6 posts
tcollings posted:
Has anyone tried the publisher with Build 600? If so, does it work?


Yes, MT4 publisher works on my end.

PipInvestor
Feb 06 2014 at 07:31
14 posts
Confirmed. Build 600 and Myfxbook EA works fine😎

Andres Marin (Andresfel)
Feb 06 2014 at 07:37
5 posts
Me too... =(

El control del riesgo sobre la evolución inmediata para perpetuar el progreso
khalil disi (khalildisi)
Feb 06 2014 at 07:37
29 posts
SolidPips (Abago)
Feb 06 2014 at 10:57
33 posts
I run the latest version 1.6 and it does to install a dll file. Where is the dll file? It's not in the \libraries directory.

"The market can stay irrational longer than you can stay solvent." - John Keynes
garyf
Feb 06 2014 at 11:16
9 posts
Staff posted:
Hi Guys,

A new version was released last week (which works on build 600) - please download it here:

https://static.mfbcdn.net/pages/EaInstaller.exe


Hi, I did try this 'new' installer but I can see that it put the .ex4 & .dll files in the old experts & experts\libraries folders which still exist after the build 600 update. Even manually coying them into the new folders (via MT4 File Open Data Folder) does not work. The EA is poicked up and found, the log shows successful MyFxBook publishing and the MyFxBook site also says updated x mins ago successfully BUT THE LATEST TRADE HISTORY IS NOT PUBLISHED SINCE THE BUILD 600 UPDATE TOOK PLACE.

So I think there is still anissue with the EA.

All the best,
Gary.

tcollings
Feb 06 2014 at 11:19
18 posts
Didn't work for me either. WHen I ran the installer however, I couldn't see the ex4 or dll files in either folders (ie: old and new), although the installer said it worked successfully.

CrazyTraderfx (CrazyTrader)
Feb 06 2014 at 11:49
1718 posts
I just tried it and it works fine.

Now Dll files are included into the EA.






Attachments:


taxfreelt
Feb 06 2014 at 13:22
9 posts
Still not working with the new installer too. In EA list Myfxbook EA looking like at picture ( grey colored ) and not working. Could anyone share not new installer but working on 600 build Myfxbook.ex4 and MyfxbookEA.dll ?

Attachments:


Please login to comment .