To use chat, please login.
Back to contacts

MyFxBook EA and Metatrader 4 - Build 600

garyf
Feb 06 2014 at 14:42
9 posts
The EA will will always appear grey as it is a .ex4 (compiled) and not a .MQL4 (source).

If you are reporting that the updated version is working and publishing, just check that newly closed trades (i.e. post the Build 600 update) are actually appearing. My Experts tab is stating that statements are being uploaded successfully and on the MyFxBookpage it also says updated x mins ago, but none of the new trades are there - just the old pre-build 600 ones.

I used the link that was posted in this thread for the new installer which still resulted in both a .ex4 & .dll file being installed in the old locations and not a combined single file as CrazyTrader states above. I then had to copy them to the new \Experts and \Libraries folders.

CrazyTrader - do you have a completely new (fresh) build 600 install as perhaps the installer is looking to see if the old \experts file structure exists and is doing things differently depending on dirs it finds.

I'm sure the 'raw' new EA (without DLL - if that is true) will be availbale to copy from here soon outside of the installer and I can try pasting that in the correct new directory (use actual MT4 menu option 'Open Data Folder' to place them - if you try to put them in the MQL4\Experts or MQL4\Libraries directory directly it will not pick them up. Also note the new capitalisation of the directory names.

All the best,
Gary.

garyf
Feb 06 2014 at 14:48
9 posts
Official download page is still showing both a .ex4 & .dll file (scroll to the end where you can download the files) :-

https://www.myfxbook.com/help/connect-metatrader-ea

Perhaps this still needs tro be updated with the new EA...

All the best,
Gary.

Staff (Staff)
Feb 06 2014 at 14:53
1390 posts
The ex4 and the dll at the bottom of the page is for build 509 (we havn't updated it yet.)

As to the new version - is doesn't use the MyfxbookEA.dll that's why you don't see it after the install.

Please make sure your run the installer as Admin (right click->run as administrator)

khalildisi (khalildisi)
Feb 06 2014 at 14:58
29 posts
thanks it work with me now

fatboy11
Feb 06 2014 at 14:58
4 posts
Agree with garyf - have installed using new installer but new version of myfxbookea is not updating any trades taken post MT4 Build 600

taxfreelt
Feb 06 2014 at 15:05
9 posts
in advisors tab in MT4 i see only Myfxbook EURUSD M5 ( where attached EA ) : Can't open file

Staff (Staff)
Feb 06 2014 at 16:00
1390 posts
taxfreelt posted:
in advisors tab in MT4 i see only Myfxbook EURUSD M5 ( where attached EA ) : Can't open file


Make sure you allow DLL imports (options->Expert Advisors->'allow DLL imports').

The EA files were added to the help section, if for some reason the installer doesn't work please install manually.

https://www.myfxbook.com/help/connect-metatrader-ea (bottom of the page->build 600)

garyf
Feb 06 2014 at 16:01
9 posts
Staff posted:
The ex4 and the dll at the bottom of the page is for build 509 (we havn't updated it yet.)

As to the new version - is doesn't use the MyfxbookEA.dll that's why you don't see it after the install.

Please make sure your run the installer as Admin (right click->run as administrator)


Ok Ethan, I tried it again for you as you seem to be saying something I can trust. So I deleted the old .ex4 and .dll files again from the old directory structure still left behind after the MT4 Build 600 update as I did last time. I used the new Installer link provided :-

https://static.mfbcdn.net/pages/EaInstaller.exe

It executes fine, but it again places a .ex4 and .dll in the OLD directory structure - i.e. / experts and /experts/libraries. So it is still trying to install a DLL and putting files in the old locations. So when you restart MT4 the EA is not listed. If I copy both files into the new directory structure (from within MT4 as described earlier). Then the EA becomes visible, you can attach it to teh chart, it reports successful updates but yet new trades are still not written back.

I still think there is a bug in how, what and where the installer is installing files...

If you publish the new EA I'll pop it directly into the correct directory and see how we go from there :-)

All the best,
Gary.

togr (togr)
Feb 06 2014 at 16:11
4862 posts
Setup place files in wrong locations
to program files 86 metatrader
it should place it under user, AppData, roaming ...

garyf
Feb 06 2014 at 16:22
9 posts
Staff posted:
taxfreelt posted:
in advisors tab in MT4 i see only Myfxbook EURUSD M5 ( where attached EA ) : Can't open file


Make sure you allow DLL imports (options->Expert Advisors->'allow DLL imports').

The EA files were added to the help section, if for some reason the installer doesn't work please install manually.

https://www.myfxbook.com/help/connect-metatrader-ea (bottom of the page->build 600)


Hi Ethan, so I gave up on the Installer. I did follow the new instructions for manual install from the updated page at link in your reply. I've put them into the correct folders using MT4 File Open Data Folder and here's what I get (***** blanked out on purpose) :-

11:07:38 Expert Myfxbook GBPJPYf,H1: loaded successfully
11:08:12 Myfxbook GBPJPYf,H1 inputs: Myfxbook_Email=********; Myfxbook_Password=*******; Publish_Interval_Minutes=5;
11:08:14 Myfxbook GBPJPYf,H1: -DLL not allowed
11:08:14 Myfxbook GBPJPYf,H1: httpPOST:: -Error Open= 0
11:08:14 Myfxbook GBPJPYf,H1: -DLL not allowed
11:08:14 Myfxbook GBPJPYf,H1: httpPOST:: -Error Open= 0
11:08:14 Myfxbook GBPJPYf,H1: Myfxbook servers are down for maintenance - please try again later
11:08:14 Myfxbook GBPJPYf,H1: initialized
11:14:22 Myfxbook GBPJPYf,H1: -DLL not allowed
11:14:22 Myfxbook GBPJPYf,H1: httpPOST:: -Error Open= 0
11:14:22 Myfxbook GBPJPYf,H1: -DLL not allowed
11:14:22 Myfxbook GBPJPYf,H1: httpPOST:: -Error Open= 0
11:14:22 Myfxbook GBPJPYf,H1: Myfxbook servers are down for maintenance - please try again later

I've allowed DLL calls as normal, but have this error now. Thanks for your help so far! :-)

I'm sure we'll get it sorted soon...

All the best,
Gary.

Please login to comment .